将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 3529|回复: 2
收起左侧

VLAN接口动态获取IP地址配置

[复制链接]
发表于 2018-5-23 21:17:57 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
VLAN接口动态获取IP地址配置: g3 {8 X- N3 r+ q! S( ]
/ S8 l$ E( C3 P( \$ q  D$ D! I# W
『配置环境参数』  o/ O7 E3 ]/ P

! T5 z5 K* O* [- B  u1.SwitchA为二层交换机,管理VLAN为VLAN10
4 P; ~% p& D: F& A$ n4 \, u  M/ n. A7 H, z
2.SwitchA的以太网端口E0/1为Trunk端口,连接到SwitchB,同时SwitchB提
" Y' b7 R. u7 N" P! {' t供DHCP Server功能4 \) Z' `+ L2 L3 \7 l
' h/ j$ ^' }- M4 ?! U8 y" @
『组网需求』
+ X5 A; S9 @) P5 r0 F7 I2 T9 K' S0 M7 [- q
SwitchA的VLAN接口10动态获取IP地址数据
5 {' I' @/ Z7 y; F) V6 R$ m
# _$ V: l7 p; J8 j配置步骤
; \. @4 o, t+ v2 k. T+ |$ Z+ D
/ N, s# L; |8 o『VLAN接口动态获取IP地址配置流程』
" f2 p% j3 o$ ~: Z# v& v# ?( O; \5 R. H+ K
在VLAN接口上配置动态获取IP地址。
6 Y6 q. W) H# x% Y8 \) Q
: L+ N& F; R( X$ M【SwitchA相关配置】3 n8 S. i  F1 H# O  E8 }! Z6 @
* B9 S( ?: S  I* Y. B
1.将E0/1端口设为trunk,并允许所有的vlan通过/ Z/ g8 J8 K. s* g. i* y

' ^' x. `/ _! K1 O[SwitchA-Ethernet0/1]port link-type trunk; _1 r; h' b1 P
, e% y- F' Z# {8 L
[SwitchA-Ethernet0/1]port trunk permit vlan all
9 [6 q" [& s2 K1 I3 t+ \
7 {1 K) z" E4 c% F4 \! K! R4 n2.创建(进入)VLAN10
& p6 I; ~5 A2 x+ g
( u7 ~7 a0 S3 D! W[SwitchA]vlan 10
 楼主| 发表于 2018-5-23 21:20:45 | 显示全部楼层
配置中继
1 p5 S' K' L# O6 h+ F步骤 交换机1命令 交换机2命令 作用: N; a* Q4 H" T7 u5 j) s6 T4 ]
1 SW1#config terminal SW2#config terminal 进入特权模式
! O+ T/ Z* k' k9 G0 F: G& Z2 SW1(config)#interface f0/24 SW2(config)#interface f0/24 进入接口配置模式  j6 y" |. \* k
3 SW1(config-if)#switchport mode trunk SW2(config-if)#switchport mode trunk 将F0/24口配置为中继, |/ q& }2 H2 t  b* M* F$ f
4 SW1(config-if)#end SW2(config-if)#end 返回特权模式
, M  j. O4 g$ h# V& X! z8 u5 SW1#show interface f0/24 switchport SW2#show interface f0/24 switchport 查看F0/24的中继状态
$ U: B# f$ u3 s; x2 L四、将接口加入vlan" P: A. V7 e' a* t* x& G8 L0 F# S
步骤 交换机1命令 交换机2命令 作用( R) f; p( E2 u1 b7 O
1 SW1#config terminal SW2#config terminal 进入特权模式) _9 m* y# O/ P
2 SW1(config)#interface range f0/1 - 10 SW2(config)#interface range f0/1 - 10 进入接口配置模式
! `9 C" Y: `# y1 Y  ?) wSW1(config-if-range)#switchport access vlan 2 SW1(config-if-range)#switchport access vlan 2 将f0/1-10分配给valn2
$ H% [5 }, ~2 z9 a- C! @4 `9 LSW1(config-if-range)#interface range f0/11 – 20 SW1(config-if-range)#interface range f0/11 – 20 进入f0/11-20的接口配置模式1 F3 f: p2 T) [
SW1(config-if-range)#switchport access vlan 3 SW1(config-if-range)#switchport access vlan 3 将接口分配vlan 3* }$ E' A. i; f# Y& s$ I
SW1(config-if-range)#end SW1(config-if-range)#end 返回特权模式( v% [* g2 T" k5 l0 J9 D
SW1#show vlan brief SW1#show vlan brief 查看vlan 情况
发表于 2018-5-23 22:40:51 | 显示全部楼层
用交换机根据端口划分vlan。
" D" s4 I( Z/ Fswitch#vlan database
& I- h" U0 k2 aswitch(vlan)#vlan 10 name v1) y/ b) f3 e% m( s" f
//此步为划分出一个id是10名字是v1的vlan% i5 @8 ]+ b! T! B; n6 j* D5 @
switch(vlan)#exit! Z- r- {& F: [3 \$ Q; X4 p
switch#configure terminal/ O# ~- U4 U& X9 B! \& M! P
switch(config)#interface f0/14 k4 ]! [. ?2 j$ T
switch(config-if)#switchport access vlan 103 S  g. z$ B1 ?2 _  i# A
//此步为把f0/1划分给vlan 10,即与f0/1相连的计算机划分给vlan 10。# H0 u; y  x+ B" `. @0 n' p: A, j5 L
switch(config-if)#interface f0/2* S* U$ z+ N: O8 D
switch(config-if)#switchport mode trunk
' i, [  b" w5 [//f0/2为交换机间的接口。/ F: Q! S7 s) a1 [
//此步为把两台交换机间的接口配置成trunk模式,以便不同vlan能通信。; T4 N1 m# {) ?6 l) R
如果要实现线路冗余,可在交换机间配置快速生成树。- S% T2 B- r$ ~( O5 e4 Z$ P: g
switch(config)#spanning-tree vlan 10
$ E! P9 }( u9 C& |' y: fswitch(config)#spanning-tree mode rapid-pvst
; f: U; f! L/ `用路由器实现vlan间通信,防止外部访问本公司网络。
$ |$ a. I2 [/ ^( k* Xrouter(config)#interface f0/2: T: i8 G- s; O2 i
//f0/2为路由器与交换机之间的接口。8 f% D. w0 Y6 t+ A! P
router(config-if)#no shutdown
" N( q3 s9 c/ a4 \4 ^router(config-if)#interface f0/0.10
! ~8 \! b9 w' [% G! `% N6 Trouter(config-subif)#encapsulation dot1q 10
4 B0 Z5 z/ d% u( C3 R( x! O  ^//10为vlanid
! l, v' N; f7 e# P8 Y2 g8 u. Lrouter(config-subif)#ip address 192.168.1.1 255.255.255.02 m* K/ `) R2 s, [2 i  f
//此步为配置单臂路由,实现vlan间通信。+ A9 D4 l9 N/ c# V/ G' b$ v
router(config)#access-list 1 deny 10.10.1.0 0.0.0.255
5 Z% D( A, ~, d3 y% \) arouter(config)#access-list 1 deny 10.10.2.0 0.0.0.255/ R% J/ H1 s+ i7 V% V
//10.10.1.0和10.10.10.2.0为内网ip。
& S% Z0 s+ i( M& ~4 [3 W8 u9 yrouter(config)#access-list 1 permit any
: i. c9 p4 C) @9 X# v; {$ prouter(config)#interface f0/0
* C" m3 \4 |# C) L' ?router(config-if)#ip access-group 1 out, S+ V" r$ v( G! k0 x
//f0/0为路由器与外网接口。6 L5 R" f* M2 q! A0 k* z6 w# j- X5 u( ]
//此步配置访问控制列表,限制外网访问内网。* e9 t4 ?7 {" }9 b1 H$ e
以上配置全是思科的设备。
3 ~* J1 L. o- I3 m; |6 B内部网络用私有ip地址即可。私有ip地址网段分别为10.0.0.0-10.255.255.255和172.16.0.0-172.31.255.255和192.168.0.0-192.168.255.255. r/ r: w5 a% y8 W- o
不同vlan的ip可以在同网段,也可以不同。
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2021-6-20 20:19 , Processed in 0.050714 second(s), 22 queries .

Powered by 龙睿 bbs168x X3.2

© 2001-2020 Comsenz Inc.

快速回复 返回顶部 返回列表